User Tools

Site Tools


mac:java

Java

We occasionally program in Java, but quite a few of the programs that we run require Java.

Java 6 is no longer supported, but some apps that we use still require it. (Specifically RubyMine and Eclipse.) So we install the Java 6 JRE from Apple and the Java 7 JDK from Oracle. This seems to work well – as long as Java 6 is installed before Java 7.

Installation

First we install the latest Java 6 JRE from Apple (1.6.0_65). Click on the download button. Open the image file that gets downloaded and install the package.

Next we install the latest Java 7 JDK from Oracle. Click on the download button under JDK. Accept the license agreement and click on the link for the Mac OS X package. Open the image file that gets downloaded and install the package.

mac/java.txt · Last modified: 2013/10/28 17:50 by Craig Buchek